summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-02-19 16:00:48 -0600
committerJoel Sherrill <joel@rtems.org>2016-04-14 16:28:10 -0500
commit8228548d127dd73439615f45f38f92b8a42bcfed (patch)
treeb7a48c833e30bcbd736f649815129c8aff2201f4 /cpukit/posix/Makefile.am
parentposix: Run key destructors during thread restart (diff)
downloadrtems-8228548d127dd73439615f45f38f92b8a42bcfed.tar.bz2
Add pthread_getconcurrency() and pthread_setconcurrency()
This is the very simple implementation specified by the Open Group for implementations with 1:1 kernel thread to user thread mappings. http://pubs.opengroup.org/onlinepubs/9699919799/functions/pthread_getconcurrency.html updates #2680.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index ed62232b72..12427d5896 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -126,6 +126,7 @@ libposix_a_SOURCES += src/pthreadatfork.c src/pthreadattrdestroy.c \
src/pthreadattrsetstack.c src/pthreadattrsetstacksize.c \
src/pthreadgetattrnp.c \
src/pthreadattrgetguardsize.c src/pthread.c \
+ src/pthreadconcurrency.c \
src/pthreadcreate.c src/pthreaddetach.c src/pthreadequal.c \
src/pthreadexit.c src/pthreadgetcpuclockid.c \
src/pthreadgetschedparam.c \