summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-09-26 07:49:17 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-10-05 14:29:02 +0200
commit5222488573e3ba8c2eceffe29f878a73a3a81694 (patch)
tree4b4ca72268b8f40da493ca252780c197bd23a5ef /cpukit/posix/Makefile.am
parentposix: Implement self-contained POSIX rwlocks (diff)
downloadrtems-5222488573e3ba8c2eceffe29f878a73a3a81694.tar.bz2
posix: Implement self-contained POSIX condvar
POSIX condition variables are now available in all configurations and no longer depend on --enable-posix. Update #2514. Update #3113.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am21
1 files changed, 10 insertions, 11 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index b69ca23132..99d1e7d08e 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -17,6 +17,7 @@ include_rtems_posix_HEADERS = include/rtems/posix/sigset.h
## Some POSIX threads features are needed all the time
include_rtems_posix_HEADERS += include/rtems/posix/barrierimpl.h
+include_rtems_posix_HEADERS += include/rtems/posix/condimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/key.h
include_rtems_posix_HEADERS += include/rtems/posix/keyimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/config.h
@@ -34,8 +35,6 @@ include_HEADERS += include/mqueue.h
# include/rtems/posix
include_rtems_posix_HEADERS += include/rtems/posix/aio_misc.h
-include_rtems_posix_HEADERS += include/rtems/posix/cond.h
-include_rtems_posix_HEADERS += include/rtems/posix/condimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/mmanimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/mqueue.h
include_rtems_posix_HEADERS += include/rtems/posix/mqueueimpl.h
@@ -72,6 +71,15 @@ libposix_a_SOURCES += src/barrierattrdestroy.c src/barrierattrgetpshared.c \
src/pbarrierdestroy.c src/pbarrierinit.c \
src/pbarrierwait.c
+## CONDITION_VARIABLE_C_FILES
+libposix_a_SOURCES += src/condattrdestroy.c \
+ src/condattrinit.c \
+ src/condattrgetpshared.c src/condattrsetpshared.c \
+ src/condattrgetclock.c src/condattrsetclock.c \
+ src/condbroadcast.c src/conddefaultattributes.c src/conddestroy.c \
+ src/condinit.c src/condsignal.c src/condsignalsupp.c \
+ src/condtimedwait.c src/condwait.c src/condwaitsupp.c
+
if HAS_PTHREADS
libposix_a_SOURCES += src/pthreadatfork.c
@@ -80,15 +88,6 @@ libposix_a_SOURCES += src/cancel.c \
src/cleanuppush.c src/setcancelstate.c \
src/setcanceltype.c src/testcancel.c
-## CONDITION_VARIABLE_C_FILES
-libposix_a_SOURCES += src/cond.c src/condattrdestroy.c \
- src/condattrinit.c \
- src/condattrgetpshared.c src/condattrsetpshared.c \
- src/condattrgetclock.c src/condattrsetclock.c \
- src/condbroadcast.c src/conddefaultattributes.c src/conddestroy.c \
- src/condinit.c src/condsignal.c src/condsignalsupp.c \
- src/condtimedwait.c src/condwait.c src/condwaitsupp.c src/condget.c
-
## MEMORY_C_FILES
libposix_a_SOURCES += src/mlockall.c
libposix_a_SOURCES += src/mlock.c