summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2011-05-16 13:55:17 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2011-05-16 13:55:17 +0000
commit5153d879c9cca60bd6630e5e8aa2cbf2abd1ac38 (patch)
treee5256e37e9f26ca89b46f4d64c49919af35af279 /cpukit/posix/Makefile.am
parentHousekeeping (diff)
downloadrtems-5153d879c9cca60bd6630e5e8aa2cbf2abd1ac38.tar.bz2
2011-05-16 Ralf Corsépius <ralf.corsepius@rtems.org>
* posix/Makefile.am: Add posixtime.h. * posix/src/clockgetres.c, posix/src/clockgettime.c, posix/src/clocksettime.c: Use CLOCK_PROCESS_CPUTIME_ID, CLOCK_THREAD_CPUTIME_ID. Include posix/src/posixtime.h. * posix/src/posixtime.h: New.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 34e1cfa0ab..2eac9a921e 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -16,6 +16,7 @@ libposix_a_SOURCES =
# Some POSIX functions that are nice to always have
libposix_a_SOURCES += src/nanosleep.c src/clockgettime.c src/clocksettime.c \
src/clockgetres.c src/sysconf.c
+libposix_a_SOURCES += src/posixtime.h
include_rtems_posixdir = $(includedir)/rtems/posix