summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-09 22:08:31 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-09 22:08:31 +0000
commit4d3200628dc294e793b5a7512141de4c1f09649c (patch)
tree4e6d12167019f6de6fb1f6cbf330911911db4671 /cpukit/posix/Makefile.am
parent2008-01-09 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-4d3200628dc294e793b5a7512141de4c1f09649c.tar.bz2
2008-01-09 Joel Sherrill <joel.sherrill@OARcorp.com>
* posix/Makefile.am, posix/include/rtems/posix/cond.h, posix/include/rtems/posix/mutex.h, posix/inline/rtems/posix/cond.inl, posix/inline/rtems/posix/mutex.inl: Do not include POSIX Mutex or Condition Variable object get helpers because they are more complicated than the norm. They can implicitly perform a create. They cross the line as being too complex and large to inline since they negatively impact size and binary test coverage. * posix/src/condget.c, posix/src/mutexget.c: New files.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index aff6cf127e..a8912fb3d3 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -77,7 +77,7 @@ libposix_a_SOURCES += src/cond.c src/condattrdestroy.c \
src/condattrgetpshared.c src/condattrinit.c src/condattrsetpshared.c \
src/condbroadcast.c src/conddefaultattributes.c src/conddestroy.c \
src/condinit.c src/condsignal.c src/condsignalsupp.c \
- src/condtimedwait.c src/condwait.c src/condwaitsupp.c
+ src/condtimedwait.c src/condwait.c src/condwaitsupp.c src/condget.c
## KEY_C_FILES
libposix_a_SOURCES += src/key.c src/keycreate.c src/keydelete.c \
@@ -105,7 +105,7 @@ libposix_a_SOURCES += src/mutex.c src/mutexattrdestroy.c \
src/mutexdestroy.c src/mutexgetprioceiling.c src/mutexinit.c \
src/mutexlock.c src/mutexlocksupp.c src/mutexsetprioceiling.c \
src/mutextimedlock.c src/mutextranslatereturncode.c src/mutextrylock.c \
- src/mutexunlock.c
+ src/mutexunlock.c src/mutexget.c
## PTHREAD_C_FILES
libposix_a_SOURCES += src/pthread.c src/pthreadsetcputime.c \