summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
commit3d1de205f620197d40ad019eb2d9e2dd5f0525c2 (patch)
treee4feaad3efa5aede8330a49535ef909658e24c77 /cpukit/posix/Makefile.am
parent2004-01-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-3d1de205f620197d40ad019eb2d9e2dd5f0525c2.tar.bz2
2004-01-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS.
Diffstat (limited to '')
-rw-r--r--cpukit/posix/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 3c97a0f671..ab5b4824d7 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -174,12 +174,13 @@ not:
EXTRA_DIST += $(C_FILES) $(UNUSED_C_FILES)
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/$(dirstamp)
if HAS_POSIX
$(PROJECT_INCLUDE)/sched.h: include/sched.h $(PROJECT_INCLUDE)/$(dirstamp)
@@ -201,7 +202,7 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/semaphore.h
$(PROJECT_INCLUDE)/rtems/posix/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/posix
@: > $(PROJECT_INCLUDE)/rtems/posix/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/posix/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/posix/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/posix/cancel.h: include/rtems/posix/cancel.h $(PROJECT_INCLUDE)/rtems/posix/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/posix/cancel.h
@@ -354,5 +355,6 @@ endif
endif
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/local.am