summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorGlenn Humphrey <glenn.humphrey@oarcorp.com>2007-11-30 20:50:42 +0000
committerGlenn Humphrey <glenn.humphrey@oarcorp.com>2007-11-30 20:50:42 +0000
commit340b7c80a497b6fa03fef74f343c9ff87f0fe6c9 (patch)
tree7cbe7a0b8f91a0629b95e0ae04f53e37db138478 /cpukit/posix/Makefile.am
parent2007-11-30 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-340b7c80a497b6fa03fef74f343c9ff87f0fe6c9.tar.bz2
2007-11-30 Glenn Humphrey <glenn.humphrey@OARcorp.com>
* posix/Makefile.am: Restructed to move the OBJECTS_LOCAL case to the top of the switch statement and eliminate the fall-through return of POSIX_BOTTOM_REACHED. These changes produced simplier assembly code and allowed for complete test coverage. Also applied some consistency to the functions that translate the core status codes to POSIX status codes.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 85ae1bd7ba..3a09c799d3 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -11,6 +11,7 @@ if LIBPOSIX
AM_CPPFLAGS += -D__RTEMS_INSIDE__
+project_lib_LIBRARIES = libposix.a
noinst_LIBRARIES = libposix.a
libposix_a_CPPFLAGS = $(AM_CPPFLAGS)
libposix_a_SOURCES =
@@ -98,9 +99,9 @@ libposix_a_SOURCES += src/mutex.c src/mutexattrdestroy.c \
src/mutexattrgetpshared.c src/mutexattrinit.c \
src/mutexattrsetprioceiling.c src/mutexattrsetprotocol.c \
src/mutexattrsetpshared.c src/mutexdefaultattributes.c \
- src/mutexdestroy.c src/mutexfromcorestatus.c src/mutexgetprioceiling.c \
- src/mutexinit.c src/mutexlock.c src/mutexlocksupp.c \
- src/mutexsetprioceiling.c src/mutextimedlock.c src/mutextrylock.c \
+ src/mutexdestroy.c src/mutexgetprioceiling.c src/mutexinit.c \
+ src/mutexlock.c src/mutexlocksupp.c src/mutexsetprioceiling.c \
+ src/mutextimedlock.c src/mutextranslatereturncode.c src/mutextrylock.c \
src/mutexunlock.c
## PTHREAD_C_FILES
@@ -140,9 +141,10 @@ libposix_a_SOURCES += src/prwlock.c src/prwlockdestroy.c src/prwlockinit.c \
## SEMAPHORE_C_FILES
libposix_a_SOURCES += src/semaphore.c src/semaphorecreatesupp.c \
src/semaphoredeletesupp.c src/semaphorenametoid.c \
- src/semaphorewaitsupp.c src/semclose.c src/semdestroy.c \
- src/semgetvalue.c src/seminit.c src/semopen.c src/sempost.c \
- src/semtimedwait.c src/semtrywait.c src/semunlink.c src/semwait.c
+ src/semaphoretranslatereturncode.c src/semaphorewaitsupp.c \
+ src/semclose.c src/semdestroy.c src/semgetvalue.c src/seminit.c \
+ src/semopen.c src/sempost.c src/semtimedwait.c src/semtrywait.c \
+ src/semunlink.c src/semwait.c
## SPINLOCK_C_FILES
libposix_a_SOURCES += src/pspin.c src/pspindestroy.c src/pspininit.c \