summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-11-06 16:16:56 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-11-20 12:57:33 -0600
commit287843f14c2ed7bd3c02f837ac1d70d6a2659e22 (patch)
treea8df35c4b879d7000c77250f7925a5bf0f5ed033 /cpukit/posix/Makefile.am
parentlibdl/.../mips/machine/elf_machdep.h: Fix typo so compiles (diff)
downloadrtems-287843f14c2ed7bd3c02f837ac1d70d6a2659e22.tar.bz2
sys/mman.h: New file. Clean up and add supporting stubs
* Makefile.am updated and preinstall.am regenerated. * mprotect.c had a prototype removed now that we have mman.h * mmap.c, munmap.c: New stub files.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 346b65aa2d..9d6fd48f59 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -91,7 +91,9 @@ libposix_a_SOURCES += src/cond.c src/condattrdestroy.c \
src/condtimedwait.c src/condwait.c src/condwaitsupp.c src/condget.c
## MEMORY_C_FILES
+libposix_a_SOURCES += src/mmap.c
libposix_a_SOURCES += src/mprotect.c
+libposix_a_SOURCES += src/munmap.c
## MESSAGE_QUEUE_C_FILES
libposix_a_SOURCES += src/mqueue.c src/mqueueclose.c \