summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-01-19 12:11:47 -0600
committerJoel Sherrill <joel@rtems.org>2016-01-19 12:11:47 -0600
commit22bb1b61cb4efe0c0dbe41057aac83bb5cffb5d3 (patch)
treeeb390a0a512494bc180d633fa5784dee84a38c5a /cpukit/posix/Makefile.am
parentpsxtests: Fix link-time errors (diff)
downloadrtems-22bb1b61cb4efe0c0dbe41057aac83bb5cffb5d3.tar.bz2
posix/src/exec*: Remove all variants already in Newlib
The RTEMS build of Newlib includes implementations of all exec*() variants. They rely on the _execve() support method. RTEMS already had this and it returned ENOSYS. There is no functional change. closes #2537.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 5a63076cc7..ad9d29f998 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -61,9 +61,7 @@ libposix_a_SOURCES += src/aio_cancel.c src/aio_error.c src/aio_fsync.c \
src/aio_read.c src/aio_return.c src/aio_suspend.c src/aio_write.c \
src/lio_listio.c src/aio_misc.c
-## ENOSYS_C_FILES
-libposix_a_SOURCES += src/_execve.c src/execl.c src/execle.c src/execlp.c \
- src/execv.c src/execve.c src/execvp.c
+libposix_a_SOURCES += src/_execve.c
endif
libposix_a_SOURCES += src/fork.c src/vfork.c