summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-07-19 14:39:45 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-07-22 16:57:23 +0200
commit0e8656b49eecdff64d639e765ef861cd974392e9 (patch)
tree02f825c7ef59c2d12dddd61a123fcd393b56fefa /cpukit/posix/Makefile.am
parentposix: Create pthread implementation header (diff)
downloadrtems-0e8656b49eecdff64d639e765ef861cd974392e9.tar.bz2
posix: Create rwlock implementation header
Move implementation specific parts of rwlock.h and rwlock.inl into new header file rwlockimpl.h. The rwlock.h contains now only the application visible API.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index f378209ee7..6e69fdd6bd 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -49,11 +49,11 @@ include_rtems_posix_HEADERS += include/rtems/posix/timer.h
include_rtems_posix_HEADERS += include/rtems/posix/barrier.h
include_rtems_posix_HEADERS += include/rtems/posix/barrierimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/rwlock.h
+include_rtems_posix_HEADERS += include/rtems/posix/rwlockimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/spinlock.h
include_rtems_posix_HEADERS += inline/rtems/posix/key.inl
include_rtems_posix_HEADERS += inline/rtems/posix/timer.inl
-include_rtems_posix_HEADERS += inline/rtems/posix/rwlock.inl
include_rtems_posix_HEADERS += inline/rtems/posix/spinlock.inl
## src