summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-16 19:12:19 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-16 19:12:19 +0000
commit0d8dad9275645fed45d58be3dae1b8e0dd722229 (patch)
treedc9e603b43d8dc5e0e5503065e8a203eed1257a6 /cpukit/posix/Makefile.am
parent2010-06-16 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-0d8dad9275645fed45d58be3dae1b8e0dd722229.tar.bz2
2010-06-16 Joel Sherrill <joel.sherrilL@OARcorp.com>
PR 1453/cpukit * posix/Makefile.am: newlib uses sysconf() for _CLOCKS_PER_SEC_ so enable it even when POSIX threads are disabled.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index f240fc5539..a269c70b86 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -14,10 +14,9 @@ libposix_a_CPPFLAGS = $(AM_CPPFLAGS)
libposix_a_SOURCES =
# Some POSIX functions that are nice to always have
-## 20 Nov 2008: Now using these from newlib's posix directory
libposix_a_SOURCES += src/sleep.c src/usleep.c
libposix_a_SOURCES += src/nanosleep.c src/clockgettime.c src/clocksettime.c \
- src/clockgetres.c
+ src/clockgetres.c src/sysconf.c
include_rtems_posixdir = $(includedir)/rtems/posix
@@ -189,7 +188,7 @@ EXTRA_DIST += src/README.mqueue
libposix_a_SOURCES += src/sched_getparam.c src/sched_getprioritymax.c \
src/sched_getprioritymin.c src/sched_getscheduler.c \
src/sched_rr_get_interval.c src/sched_setparam.c \
- src/sched_setscheduler.c src/sched_yield.c src/sysconf.c
+ src/sched_setscheduler.c src/sched_yield.c
endif
include $(srcdir)/preinstall.am