summaryrefslogtreecommitdiffstats
path: root/cpukit/librpc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-10 06:27:10 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-04 08:02:28 +0200
commite069f7fe566f93e50d2559c04ff31cc334748e51 (patch)
tree2dc151c927dc8e60a7efca86f4e3ae433bfb562d /cpukit/librpc/Makefile.am
parentUse rtems_task_exit() (diff)
downloadrtems-e069f7fe566f93e50d2559c04ff31cc334748e51.tar.bz2
rpc: Use configuration header file
Update #3375.
Diffstat (limited to '')
-rw-r--r--cpukit/librpc/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/cpukit/librpc/Makefile.am b/cpukit/librpc/Makefile.am
index eb498287fa..b0af51bf70 100644
--- a/cpukit/librpc/Makefile.am
+++ b/cpukit/librpc/Makefile.am
@@ -19,7 +19,7 @@ if LIBNETWORKING
man_MANS += $(libxdr_mans)
noinst_LIBRARIES += librpc.a
-librpc_a_CPPFLAGS = $(AM_CPPFLAGS) $(librpc_CPPFLAGS)
+librpc_a_CPPFLAGS = $(AM_CPPFLAGS)
librpc_a_SOURCES = src/rpc/auth_none.c src/rpc/auth_unix.c \
src/rpc/authunix_prot.c src/rpc/bindresvport.c src/rpc/clnt_generic.c \
@@ -34,9 +34,6 @@ librpc_a_SOURCES = src/rpc/auth_none.c src/rpc/auth_unix.c \
src/rpc/svc_raw.c src/rpc/svc_run.c src/rpc/svc_simple.c \
src/rpc/svc_tcp.c src/rpc/svc_udp.c src/rpc/rtems_portmapper.c \
src/rpc/rtems_rpc.c
-
-librpc_CPPFLAGS = -D_RPC_read=read -D_RPC_write=write -D_RPC_close=close \
- -D_RTEMS_RPC_INTERNAL_
endif
librpc_mans = src/rpc/bindresvport.3 src/rpc/getrpcent.3 src/rpc/publickey.3 \