summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/sys/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
commitdf49c60c9671e4a28e636964d744c1f59fb6cb68 (patch)
treeeabd85e189514ad412a35414ba5d483dcda3ef1f /cpukit/libnetworking/sys/Makefile.am
parentPurged as many egcs references as possible. (diff)
downloadrtems-df49c60c9671e4a28e636964d744c1f59fb6cb68.tar.bz2
Merged from 4.5.0-beta3a
Diffstat (limited to 'cpukit/libnetworking/sys/Makefile.am')
-rw-r--r--cpukit/libnetworking/sys/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/cpukit/libnetworking/sys/Makefile.am b/cpukit/libnetworking/sys/Makefile.am
index 3fe88aff59..07888ddcc7 100644
--- a/cpukit/libnetworking/sys/Makefile.am
+++ b/cpukit/libnetworking/sys/Makefile.am
@@ -4,10 +4,22 @@
AUTOMAKE_OPTIONS = foreign 1.4
-EXTRA_DIST = buf.h callout.h cdefs.h conf.h domain.h filio.h ioccom.h \
+H_FILES = buf.h callout.h cdefs.h conf.h domain.h filio.h ioccom.h \
ioctl.h kernel.h libkern.h malloc.h mbuf.h mount.h param.h proc.h \
protosw.h queue.h reboot.h resourcevar.h rtprio.h select.h signalvar.h \
socket.h socketvar.h sockio.h sysctl.h syslimits.h syslog.h systm.h \
- ttycom.h ttydefaults.h ucred.h uio.h
+ ttycom.h ttydefaults.h ucred.h uio.h un.h
+
+noinst_HEADERS = $(H_FILES)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys $(H_FILES:%=$(PROJECT_INCLUDE)/sys/%)
+
+$(PROJECT_INCLUDE)/sys:
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/sys/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../automake/local.am