summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/netinet/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-12 12:15:00 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-12 12:15:00 +0000
commitdd695d81b6b71c781b7df92e887e433b2b0b06ad (patch)
treeaea5f0d87b460eb09e0e0290ee546bb09b8f3330 /cpukit/libnetworking/netinet/Makefile.am
parent2002-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-dd695d81b6b71c781b7df92e887e433b2b0b06ad.tar.bz2
2002-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in kern/Makefile.am, net/Makefile.am, netinet/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, rtems/Makefile.am. * kern/Makefile.am: Remove. * net/Makefile.am: Remove. * netinet/Makefile.am: Remove. * nfs/Makefile.am: Remove. * rtems/Makefile.am: Remove. * wrapup/Makefile.am: Reflect changes above. * configure.ac: Ditto.
Diffstat (limited to 'cpukit/libnetworking/netinet/Makefile.am')
-rw-r--r--cpukit/libnetworking/netinet/Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/cpukit/libnetworking/netinet/Makefile.am b/cpukit/libnetworking/netinet/Makefile.am
deleted file mode 100644
index b6ad12ff7f..0000000000
--- a/cpukit/libnetworking/netinet/Makefile.am
+++ /dev/null
@@ -1,40 +0,0 @@
-##
-## $Id$
-##
-
-include_netinetdir = $(includedir)/netinet
-
-LIB = $(ARCH)/lib.a
-
-C_FILES = if_ether.c igmp.c in.c in_cksum.c in_pcb.c in_proto.c in_rmx.c \
- ip_divert.c ip_fw.c ip_icmp.c ip_input.c ip_mroute.c ip_output.c \
- raw_ip.c tcp_debug.c tcp_input.c tcp_output.c tcp_subr.c tcp_timer.c \
- tcp_usrreq.c udp_usrreq.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-include $(top_srcdir)/../automake/multilib.am
-include $(top_srcdir)/../automake/compile.am
-include $(top_srcdir)/../automake/lib.am
-
-#
-# Add local stuff here using +=
-#
-
-# Add -DFORWARD_PROTOCOL to enable UDP forwarding -- requires missing net/pf.h
-AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
- -DBOOTP_COMPAT
-
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(PREINSTALL_FILES) $(ARCH) $(LIB)
-
-.PRECIOUS: $(LIB)
-
-EXTRA_DIST = if_ether.c igmp.c igmp_var.h in.c in_cksum.c in_cksum_i386.c \
- in_cksum_m68k.c in_cksum_powerpc.c in_pcb.c in_proto.c in_rmx.c \
- ip_divert.c ip_fw.c ip_icmp.c ip_input.c ip_mroute.c ip_output.c \
- raw_ip.c tcp_debug.c tcp_input.c tcp_output.c tcp_subr.c tcp_timer.c \
- tcp_usrreq.c udp_usrreq.c
-
-include $(top_srcdir)/../automake/local.am