summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/netinet/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-03 13:21:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-03 13:21:38 +0000
commit4bf1801d0d6fa7bcf7488f7f3cc5c39fafeac7d2 (patch)
tree5a28ef12908ea03bf2125df5b280ed1974dd02e5 /cpukit/libnetworking/netinet/Makefile.am
parentFixed spelling errors. (diff)
downloadrtems-4bf1801d0d6fa7bcf7488f7f3cc5c39fafeac7d2.tar.bz2
Patches rtems-rc-20000118-7.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that contains the automake files for libnetworking plus a couple of minor fixes. [Now only one unused/unsupported Makefile.in remains (./c/src/lib/libbsp/hppa1.1/pxfl/Makefile.in).] To apply: patch -p1 < rtems-rc-20000118-7.diff /bin/sh rtems-rc-20000118-7.rm /bin/sh rtems-rc-20000118-7.add ./bootstrap Notes: * I have tested this one by building all BSPs for m68k, powerpc, sh and unix with toolchains built since last weekend. * I did not touch libnetworking's directory layout.
Diffstat (limited to 'cpukit/libnetworking/netinet/Makefile.am')
-rw-r--r--cpukit/libnetworking/netinet/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/cpukit/libnetworking/netinet/Makefile.am b/cpukit/libnetworking/netinet/Makefile.am
new file mode 100644
index 0000000000..f967b65cd7
--- /dev/null
+++ b/cpukit/libnetworking/netinet/Makefile.am
@@ -0,0 +1,43 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = lib.a
+LIB = $(ARCH)/$(LIBNAME)
+
+C_FILES = if_ether.c igmp.c in.c in_cksum.c in_pcb.c in_proto.c in_rmx.c \
+ ip_divert.c ip_fw.c ip_icmp.c ip_input.c ip_mroute.c ip_output.c \
+ raw_ip.c tcp_debug.c tcp_input.c tcp_output.c tcp_subr.c tcp_timer.c \
+ tcp_usrreq.c udp_usrreq.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
+ -DBOOTP_COMPAT
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = icmp_var.h if_ether.c if_ether.h igmp.c igmp.h igmp_var.h in.c \
+ in.h in_cksum.c in_cksum_i386.c in_cksum_m68k.c in_cksum_powerpc.c \
+ in_pcb.c in_pcb.h in_proto.c in_rmx.c in_systm.h in_var.h ip.h \
+ ip_divert.c ip_fw.c ip_fw.h ip_icmp.c ip_icmp.h ip_input.c ip_mroute.c \
+ ip_mroute.h ip_output.c ip_var.h raw_ip.c tcp.h tcp_debug.c tcp_debug.h \
+ tcp_fsm.h tcp_input.c tcp_output.c tcp_seq.h tcp_subr.c tcp_timer.c \
+ tcp_timer.h tcp_usrreq.c tcp_var.h tcpip.h udp.h udp_usrreq.c udp_var.h
+
+include $(top_srcdir)/../../../automake/local.am