summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/net/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-05 16:07:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-05 16:07:35 +0000
commit9b28bea577dc0d6781d2895b61c07a5d311d24b5 (patch)
treed44a0b3ca8230f9d0c99a5fb3044829f312637cd /cpukit/libnetworking/net/Makefile.am
parent2000-09-04 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-9b28bea577dc0d6781d2895b61c07a5d311d24b5.tar.bz2
2000-09-04 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* kern/Makefile.am, lib/Makefile.am, libc/Makefile.am, net/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, pppd/Makefile.am, rtems/Makefile.am, rtems_servers/Makefile.am, rtems_webserver/Makefile.am, wrapup/Makefile.am: Include compile.am
Diffstat (limited to '')
-rw-r--r--cpukit/libnetworking/net/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/cpukit/libnetworking/net/Makefile.am b/cpukit/libnetworking/net/Makefile.am
index eda18a9c76..73423b7f49 100644
--- a/cpukit/libnetworking/net/Makefile.am
+++ b/cpukit/libnetworking/net/Makefile.am
@@ -14,6 +14,7 @@ C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
#
@@ -30,15 +31,16 @@ all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
.PRECIOUS: $(LIB)
-EXTRA_DIST = if.c if_ethersubr.c if_loop.c \
- radix.c raw_cb.c raw_usrreq.c route.c rtsock.c
+EXTRA_DIST = if.c if_ethersubr.c if_loop.c radix.c raw_cb.c raw_usrreq.c \
+ route.c rtsock.c
-H_FILES = bpf.h ethernet.h if.h if_arp.h if_dl.h if_llc.h if_ppp.h if_types.h \
- netisr.h ppp-comp.h ppp_defs.h radix.h raw_cb.h route.h
+H_FILES = bpf.h ethernet.h if.h if_arp.h if_dl.h if_llc.h if_ppp.h \
+ if_types.h netisr.h ppp-comp.h ppp_defs.h radix.h raw_cb.h route.h
noinst_HEADERS = $(H_FILES)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/net $(H_FILES:%=$(PROJECT_INCLUDE)/net/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/net \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/net/%)
$(PROJECT_INCLUDE)/net:
@$(mkinstalldirs) $@