summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-04-30 09:48:13 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-05-02 09:56:48 +0200
commitfea9a7a7e59f4a6f08805591200e6dd943412372 (patch)
tree8a51d2a9bf3c1715195511c2a9eef359f8c03d2e /cpukit/libnetworking/Makefile.am
parenttftpfs: Always build TFTP client (diff)
downloadrtems-fea9a7a7e59f4a6f08805591200e6dd943412372.tar.bz2
ftpfs: Always build FTP client
Move FTP client filesystem to separate library libftpfs.a. Update #3419.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 1f6be15312..372f642610 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -4,6 +4,12 @@ include $(top_srcdir)/automake/compile.am
project_lib_LIBRARIES =
TMPINSTALL_FILES =
+project_lib_LIBRARIES += libftpfs.a
+libftpfs_a_SOURCES = lib/ftpfs.c
+$(PROJECT_LIB)/libftpfs.a: libftpfs.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libftpfs.a
+TMPINSTALL_FILES += $(PROJECT_LIB)/libftpfs.a
+
project_lib_LIBRARIES += libtftpfs.a
libtftpfs_a_SOURCES = lib/tftpDriver.c
$(PROJECT_LIB)/libtftpfs.a: libtftpfs.a
@@ -134,7 +140,7 @@ lib_CPPFLAGS = -DNOPOLL -DNOSELECT
noinst_LIBRARIES += lib.a
lib_a_CPPFLAGS = $(AM_CPPFLAGS) $(lib_CPPFLAGS) -D__BSD_VISIBLE
-lib_a_SOURCES = lib/getprotoby.c lib/rtems_bsdnet_ntp.c lib/ftpfs.c \
+lib_a_SOURCES = lib/getprotoby.c lib/rtems_bsdnet_ntp.c \
lib/syslog.c
lib_a_SOURCES += rtems/rtems_syscall_api.c
endif