summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-04-30 09:24:44 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-05-02 09:56:48 +0200
commitc3bab73b4bb1b02879671d72ff96e625a1b4807e (patch)
tree0e4967c81c4e9ae913b465fecef7d55436537d13 /cpukit/libnetworking/Makefile.am
parentlibdebugger: Move to separate library (diff)
downloadrtems-c3bab73b4bb1b02879671d72ff96e625a1b4807e.tar.bz2
tftpfs: Always build TFTP client
Move TFTP client filesystem to separate library libtftpfs.a. Conditionally use legacy network stack features, e.g. BOOTP support. Update #3419.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 3ab9a274e6..1f6be15312 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -1,6 +1,14 @@
include $(top_srcdir)/automake/multilib.am
include $(top_srcdir)/automake/compile.am
+project_lib_LIBRARIES =
+TMPINSTALL_FILES =
+
+project_lib_LIBRARIES += libtftpfs.a
+libtftpfs_a_SOURCES = lib/tftpDriver.c
+$(PROJECT_LIB)/libtftpfs.a: libtftpfs.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libtftpfs.a
+TMPINSTALL_FILES += $(PROJECT_LIB)/libtftpfs.a
# poll is not supported
UNUSED_FILES = poll.h
@@ -127,7 +135,7 @@ noinst_LIBRARIES += lib.a
lib_a_CPPFLAGS = $(AM_CPPFLAGS) $(lib_CPPFLAGS) -D__BSD_VISIBLE
lib_a_SOURCES = lib/getprotoby.c lib/rtems_bsdnet_ntp.c lib/ftpfs.c \
- lib/syslog.c lib/tftpDriver.c
+ lib/syslog.c
lib_a_SOURCES += rtems/rtems_syscall_api.c
endif