summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-21 15:34:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-21 15:34:10 +0000
commit6f57450dfecbb2bad6503a53a05cf693218e57f1 (patch)
tree4b22275ec132e207943ce3e878f595fb0464eca3 /cpukit/libnetworking/Makefile.am
parent2007-09-21 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-6f57450dfecbb2bad6503a53a05cf693218e57f1.tar.bz2
2007-09-21 Joel Sherrill <joel.sherrill@oarcorp.com>
* libnetworking/Makefile.am: Add dummy socketpair() implementation to document what is required to provide a fully functional implementation. * libnetworking/rtems/rtems_socketpair.c: New file.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 9042b3139b..71f5c8d158 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -121,8 +121,9 @@ libnetworking_a_SOURCES += rtems/sghostname.c rtems/issetugid.c \
rtems/rtems_showmbuf.c rtems/rtems_showroute.c rtems/rtems_showifstat.c \
rtems/rtems_showipstat.c rtems/rtems_showicmpstat.c \
rtems/rtems_showtcpstat.c rtems/rtems_showudpstat.c rtems/rtems_select.c \
- rtems/mkrootfs.c rtems/rtems_bsdnet_malloc_starvation.c
-libnetworking_a_SOURCES += rtems/rtems_mii_ioctl.c rtems/rtems_mii_ioctl_kern.c
+ rtems/mkrootfs.c rtems/rtems_bsdnet_malloc_starvation.c \
+ rtems/rtems_mii_ioctl.c rtems/rtems_mii_ioctl_kern.c \
+ rtems/rtems_socketpair.c
## sys