summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorChristian Mauderer <Christian.Mauderer@embedded-brains.de>2016-06-24 07:57:17 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-06-28 13:09:44 +0200
commit657e6c93ef680a65ae59fa63aeef7f8c09e98cba (patch)
tree7eaccf73d4c7bf86ccd64ae104b02cd0d6a5f1ae /cpukit/libnetworking/Makefile.am
parentlibnetworking: Import current <netinet6/in6.h> (diff)
downloadrtems-657e6c93ef680a65ae59fa63aeef7f8c09e98cba.tar.bz2
libnetworking: Import current <netinet/in.h>
Import the <netinet/in.h> from current FreeBSD. This allows to build some current software (e.g. libressl). Add legacy support like * prototype for in_cksum(), * IPPORT_USERRESERVED, * deprecated IPCTL_RT* defines, * ip_fw_chk_t and ip_fw_ctl_t, * ip_nat_... (IP NAT hooks), and * IP_NAT option for get/setsockopt() to new <rtems/rtems_netinet_in.h>.
Diffstat (limited to 'cpukit/libnetworking/Makefile.am')
-rw-r--r--cpukit/libnetworking/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index 6ef2f71767..424bd25605 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -156,6 +156,7 @@ include_rtems_HEADERS += rtems/ftpfs.h
include_rtems_HEADERS += rtems/mkrootfs.h
include_rtems_HEADERS += rtems/rtems_mii_ioctl.h
include_rtems_HEADERS += rtems/rtems_netdb.h
+include_rtems_HEADERS += rtems/rtems_netinet_in.h
libnetworking_a_SOURCES += rtems/sghostname.c \
rtems/rtems_glue.c rtems/rtems_malloc_mbuf.c rtems/rtems_syscall.c \