summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-07-02 13:40:19 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-07-02 13:40:19 +0000
commit1fbd0bafe7671fce033f7672f35690c8324aaff9 (patch)
tree7bb6ef7b1a76541ad91655e53dd21185282e3b5d /cpukit/libnetworking/Makefile.am
parent2008-07-02 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-1fbd0bafe7671fce033f7672f35690c8324aaff9.tar.bz2
2008-07-02 Joel Sherrill <joel.sherrill@oarcorp.com>
* libnetworking/Makefile.am, libnetworking/libc/gethostnamadr.c, libnetworking/libc/getservbyname.c, libnetworking/libc/getservbyport.c: Add initial versions of getservbyport_r(), gethostbyaddr_r(), and getservbyport_r(). At this point they are just simple weappers for the version without the _r in the name.
Diffstat (limited to '')
-rw-r--r--cpukit/libnetworking/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index e07ec5f3df..15c6ea6c9b 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -149,7 +149,7 @@ include_dev_mii_HEADERS = dev/mii/mii.h
## libc
-libc_CPPFLAGS = -DNOPOLL -DNOSELECT -D__BSD_VISIBLE
+libc_CPPFLAGS = -DNOPOLL -DNOSELECT -D__BSD_VISIBLE -D_THREAD_SAFE
noinst_LIBRARIES += libc.a
libc_a_CPPFLAGS = $(AM_CPPFLAGS) $(libc_CPPFLAGS)