summaryrefslogtreecommitdiffstats
path: root/cpukit/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorChristian Mauderer <Christian.Mauderer@embedded-brains.de>2016-05-02 14:49:33 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-06-28 13:01:47 +0200
commit195d412d397a50383a0a2703022613d97cca2736 (patch)
treeab0fbf0f22842cffc9a4954b4f8e77319d5188bf /cpukit/libnetworking/Makefile.am
parentlibnetworking: Import current <netdb.h> (diff)
downloadrtems-195d412d397a50383a0a2703022613d97cca2736.tar.bz2
libnetworking: Add minimal getnameinfo()
This implementation just falls back to giving a string representation of the IP. It supports IPv4 only. Add test for getnameinfo().
Diffstat (limited to '')
-rw-r--r--cpukit/libnetworking/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/libnetworking/Makefile.am b/cpukit/libnetworking/Makefile.am
index c8c5f5077a..57ceee9eda 100644
--- a/cpukit/libnetworking/Makefile.am
+++ b/cpukit/libnetworking/Makefile.am
@@ -214,7 +214,7 @@ include_HEADERS += ifaddrs.h
libc_a_SOURCES = libc/base64.c \
libc/gethostbydns.c libc/gethostbyht.c libc/gethostbynis.c \
libc/gethostnamadr.c libc/getnetbydns.c libc/getnetbyht.c \
- libc/getnetbynis.c libc/getnetnamadr.c libc/getproto.c \
+ libc/getnetbynis.c libc/getnetnamadr.c libc/getnameinfo.c libc/getproto.c \
libc/getprotoent.c libc/getprotoname.c libc/getservbyname.c \
libc/getservbyport.c libc/getservent.c libc/herror.c libc/inet_addr.c \
libc/inet_lnaof.c libc/inet_makeaddr.c libc/inet_netof.c \