summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-01-24 12:05:44 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-01-24 12:05:44 +0000
commit5a8a05b2c9fce41cda685361e13a11bbf605676d (patch)
tree1bfc994310b28b708b4dbe3ef2eefa4efc473fe0 /cpukit/libmisc/wrapup/Makefile.am
parent2003-01-24 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-5a8a05b2c9fce41cda685361e13a11bbf605676d.tar.bz2
2002-01-24 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add check for weak function attribute. Remove AM_CONDITIONAL([RTEMS_LIBSHELL]. Add AM_CONDITIONAL(LIBSHELL), AM_CONDITIONAL(LIBSERDBG). * capture/Makefile.am: Use *.a instead of *-tmp.a. * cpuuse/Makefile.am: Use *.a instead of *-tmp.a. * devnull/Makefile.am: Use *.a instead of *-tmp.a. * dummy/Makefile.am: Use *.a instead of *-tmp.a. * dumpbuf/Makefile.am: Use *.a instead of *-tmp.a. * monitor/Makefile.am: Use *.a instead of *-tmp.a. * mw-fb/Makefile.am: Use *.a instead of *-tmp.a. * rtmonuse/Makefile.am: Use *.a instead of *-tmp.a. * serdbg/Makefile.am: Use *.a instead of *-tmp.a. Build iff LIBSERDBG is true. * shell/Makefile.am: Use *.a instead of *-tmp.a. Build iff LIBSHELL is true. * stackchk/Makefile.am: Use *.a instead of *-tmp.a. * untar/Makefile.am: Use *.a instead of *-tmp.a. * wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to 'cpukit/libmisc/wrapup/Makefile.am')
-rw-r--r--cpukit/libmisc/wrapup/Makefile.am27
1 files changed, 17 insertions, 10 deletions
diff --git a/cpukit/libmisc/wrapup/Makefile.am b/cpukit/libmisc/wrapup/Makefile.am
index ca804a6b09..99573ec9fc 100644
--- a/cpukit/libmisc/wrapup/Makefile.am
+++ b/cpukit/libmisc/wrapup/Makefile.am
@@ -7,20 +7,27 @@ LIB = $(ARCH)/libmisc.a
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/lib.am
-## XXX temporarily remove this from the list because it causes a
+TMP_LIBS = ../monitor/$(ARCH)/libmonitor.a
+TMP_LIBS += ../untar/$(ARCH)/libuntar.a
+TMP_LIBS += ../stackchk/$(ARCH)/libstackchk.a
+TMP_LIBS += ../cpuuse/$(ARCH)/libcpuuse.a
+TMP_LIBS += ../rtmonuse/$(ARCH)/librtmonuse.a
+
+## XXX temporarily remove this from the list because it causes a
## XXX number of BSPs to not link "main(){}" used by autoconf
-## ../serdbg/$(ARCH)/libserdbg-tmp.a
+# if LIBSERDBG
+# TMP_LIBS += ../serdbg/$(ARCH)/libserdbg.a
+# endif
-if RTEMS_LIBSHELL
-RTEMS_LIBSHELL = ../shell/$(ARCH)/libshell-tmp.a
+if LIBSHELL
+TMP_LIBS += ../shell/$(ARCH)/libshell.a
endif
-TMP_LIBS = ../monitor/$(ARCH)/libmonitor-tmp.a \
- ../untar/$(ARCH)/libuntar-tmp.a ../stackchk/$(ARCH)/libstackchk-tmp.a \
- ../cpuuse/$(ARCH)/libcpuuse-tmp.a ../rtmonuse/$(ARCH)/librtmonuse-tmp.a \
- $(RTEMS_LIBSHELL) ../dumpbuf/$(ARCH)/libdumpbuf-tmp.a \
- ../devnull/$(ARCH)/libdevnull-tmp.a ../dummy/$(ARCH)/libdummy-tmp.a \
- ../mw-fb/$(ARCH)/libmw-fb-tmp.a ../capture/$(ARCH)/libcapture-tmp.a
+TMP_LIBS += ../dumpbuf/$(ARCH)/libdumpbuf.a
+TMP_LIBS += ../devnull/$(ARCH)/libdevnull.a
+TMP_LIBS += ../dummy/$(ARCH)/libdummy.a
+TMP_LIBS += ../mw-fb/$(ARCH)/libmw-fb.a
+TMP_LIBS += ../capture/$(ARCH)/libcapture.a
#
# (OPTIONAL) Add local stuff here using +=