summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/stackchk/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-08 22:33:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-08 22:33:25 +0000
commit70810dcd8970194d96f685ffe4af890911e273c5 (patch)
treecade3ccf39b9bcabc04e7b1ce9105a83f80b177d /cpukit/libmisc/stackchk/Makefile.am
parentchanged version to 4.5.0-beta1 (diff)
downloadrtems-70810dcd8970194d96f685ffe4af890911e273c5.tar.bz2
Patches rtems-rc-20000204-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that contains: * Removes remaining (now illegal) references to $(SRC) from a couple of Makefile.ams * Removes duplicate AC_CONFIG_SUBDIRS macro from c/configure.in * Moves ENABLE_LIBCDIR into RTEMS_PROG_C[C|XX]_FOR_TARGET (hides LIBCDIR from most configure scripts, i.e. LIBCDIR becomes less visible) * Adds RTEMS_PROG_C[C|XX]_FOR_TARGET and RTEMS_CANONICALIZE_TOOLS to libbsp/*/configure.ins (A minor bug in previous implementations, which only has an impact when switching to GNU/Cygnus canonicalization) * Cleans up several bogus comments. * Removes MKLIB * Switches the version number to 4.5.0 (for testing version number handling)
Diffstat (limited to 'cpukit/libmisc/stackchk/Makefile.am')
-rw-r--r--cpukit/libmisc/stackchk/Makefile.am29
1 files changed, 14 insertions, 15 deletions
diff --git a/cpukit/libmisc/stackchk/Makefile.am b/cpukit/libmisc/stackchk/Makefile.am
index e5f467c42a..83dd699c85 100644
--- a/cpukit/libmisc/stackchk/Makefile.am
+++ b/cpukit/libmisc/stackchk/Makefile.am
@@ -1,28 +1,22 @@
-##
-## $Id$
-##
+##
+## $Id$
+##
AUTOMAKE_OPTIONS = foreign 1.4
LIBNAME = libstackchk-tmp
-LIB = ${ARCH}/${LIBNAME}.a
+LIB = $(ARCH)/$(LIBNAME).a
C_FILES = check.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
H_FILES = internal.h
INSTALLED_H_FILES = stackchk.h
-noinst_HEADERS = $(H_FILES) $(INSTALLED_H_FILES)
-SRCS = $(C_FILES) $(H_FILES) $(INSTALLED_H_FILES)
OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(RTEMS_ROOT)/make/lib.cfg
-
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems \
-$(INSTALLED_H_FILES:%=$(PROJECT_INCLUDE)/rtems/%)
+include $(top_srcdir)/../../../automake/lib.am
$(PROJECT_INCLUDE)/rtems:
@$(mkinstalldirs) $@
@@ -33,11 +27,16 @@ $(PROJECT_INCLUDE)/rtems/%.h: %.h
# (OPTIONAL) Add local stuff here using +=
#
-${LIB}: ${OBJS}
+$(LIB): $(OBJS)
$(make-library)
-all: ${ARCH} $(PREINSTALL_FILES) $(LIB) $(TMPINSTALL_FILES)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(INSTALLED_H_FILES:%=$(PROJECT_INCLUDE)/rtems/%)
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
-EXTRA_DIST += $(C_FILES)
+EXTRA_DIST = README check.c internal.h stackchk.h
include $(top_srcdir)/../../../automake/local.am