summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/stackchk/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:26:26 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:26:26 +0000
commit620e82636b5fbe1bdbc2fddd59984f2eee82707b (patch)
treeeb3ee12e05af9d4adf53172240ff48bf7ed967f1 /cpukit/libmisc/stackchk/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-620e82636b5fbe1bdbc2fddd59984f2eee82707b.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* untar/Makefile.am, monitor/Makefile.am, dummy/Makefile.am, devnull/Makefile.am, dumpbuf/Makefile.am, mw-fb/Makefile.am, stackchk/Makefile.am, rtmonuse/Makefile.am, cpuuse/Makefile.am: Apply include_*HEADERS instead of H_FILES.
Diffstat (limited to 'cpukit/libmisc/stackchk/Makefile.am')
-rw-r--r--cpukit/libmisc/stackchk/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/cpukit/libmisc/stackchk/Makefile.am b/cpukit/libmisc/stackchk/Makefile.am
index 1050293b03..f91e757208 100644
--- a/cpukit/libmisc/stackchk/Makefile.am
+++ b/cpukit/libmisc/stackchk/Makefile.am
@@ -4,14 +4,16 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_rtemsdir = $(includedir)/rtems
+
LIBNAME = libstackchk-tmp
LIB = $(ARCH)/$(LIBNAME).a
C_FILES = check.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-H_FILES = internal.h
-INSTALLED_H_FILES = stackchk.h
+noinst_HEADERS = internal.h
+include_rtems_HEADERS = stackchk.h
OBJS = $(C_O_FILES)
@@ -32,12 +34,12 @@ $(LIB): $(OBJS)
$(make-library)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
- $(INSTALLED_H_FILES:%=$(PROJECT_INCLUDE)/rtems/%)
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
.PRECIOUS: $(LIB)
-EXTRA_DIST = README check.c internal.h stackchk.h
+EXTRA_DIST = README check.c
include $(top_srcdir)/../../../automake/local.am