summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/serdbg/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-06-27 21:25:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-06-27 21:25:14 +0000
commit9e633f58da0e7a5e07da0becdd81b43ab2ea227c (patch)
tree9600a2157eec583dabde35d2eba10a47268a64f8 /cpukit/libmisc/serdbg/Makefile.am
parent2002-06-27 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-9e633f58da0e7a5e07da0becdd81b43ab2ea227c.tar.bz2
2002-06-25 Thomas Doerfler <Thomas.Doerfler@imd-systems.de>
* With the addition of serdbg, the standard polled I/O functions for gdbstub and/or printk are optionally routed to any termios-aware device driver, that supports polled mode. See libmisc/serdbg/README. * serdbg/Makefile.am, serdbg/README, serdbg/serdbg.c, serdbg/serdbg.h, serdbg/serdbgcnf.h, serdbg/serdbgio.c, serdbg/termios_printk.c, serdbg/termios_printk.h, serdbg/termios_printk_cnf.h, serdbg/.cvsignore: New files. * configure.ac, Makefile.am, wrapup/Makefile.am: Modified to reflect addition.
Diffstat (limited to '')
-rw-r--r--cpukit/libmisc/serdbg/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/cpukit/libmisc/serdbg/Makefile.am b/cpukit/libmisc/serdbg/Makefile.am
new file mode 100644
index 0000000000..d2340dfc4e
--- /dev/null
+++ b/cpukit/libmisc/serdbg/Makefile.am
@@ -0,0 +1,47 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+include_rtemsdir = $(includedir)/rtems
+
+LIBNAME = libserdbg-tmp
+LIB = $(ARCH)/$(LIBNAME).a
+
+C_FILES = serdbg.c serdbgio.c termios_printk.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+noinst_HEADERS =
+include_HEADERS = serdbgcnf.h serdbg.h termios_printk_cnf.h \
+ termios_printk.h
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE) \
+ $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = README serdbg.c serdbgio.c serdbgcnf.h serdbg.h \
+ termios_printk.c termios_printk.h termios_printk_cnf.h
+
+include $(top_srcdir)/../../../automake/local.am