summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 10:39:58 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 10:39:58 +0000
commit2cc936789e568edcad702d597aa883eeb2b50445 (patch)
treef0d439fe5c89bf9762b9c57b529da8dd568f935a /cpukit/libmisc/configure.ac
parent2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2cc936789e568edcad702d597aa883eeb2b50445.tar.bz2
2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Remove (Merged into ../configure.ac). * Makefile.am: Reflect having merged configure.ac into ../configure.ac. * capture/config.h: New. * capture/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * cpuuse/config.h: New. * cpuuse/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * devnull/config.h: New. * devnull/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * dummy/config.h: New. * dummy/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * dumpbuf/config.h: New. * dumpbuf/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * monitor/config.h: New. * monitor/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * mw-fb/config.h: New. * mw-fb/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * rtmonuse/config.h: New. * rtmonuse/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * serdbg/config.h: New. * serdbg/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * shell/config.h: New. * shell/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * stackchk/config.h: New. * stackchk/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * untar/config.h: New. * untar/Makefile.am: Add config.h. Reflect having merged configure.ac into ../configure.ac. * wrapup/Makefile.am: Reflect having merged configure.ac into ../configure.ac.
Diffstat (limited to 'cpukit/libmisc/configure.ac')
-rw-r--r--cpukit/libmisc/configure.ac76
1 files changed, 0 insertions, 76 deletions
diff --git a/cpukit/libmisc/configure.ac b/cpukit/libmisc/configure.ac
deleted file mode 100644
index 22d828f112..0000000000
--- a/cpukit/libmisc/configure.ac
+++ /dev/null
@@ -1,76 +0,0 @@
-## Process this file with autoconf to produce a configure script.
-##
-## $Id$
-
-AC_PREREQ(2.57)
-AC_INIT([rtems-cpukit-libmisc],[_RTEMS_VERSION],[rtems-bugs@OARcorp.com])
-AC_CONFIG_SRCDIR([dumpbuf])
-RTEMS_TOP(../..)
-
-RTEMS_CANONICAL_TARGET_CPU
-
-AM_INIT_AUTOMAKE([no-define foreign 1.7.2])
-AM_MAINTAINER_MODE
-
-RTEMS_ENABLE_BARE
-
-RTEMS_ENV_RTEMSCPU
-RTEMS_CHECK_CPU
-RTEMS_CANONICAL_HOST
-
-RTEMS_PROG_CC_FOR_TARGET
-RTEMS_CANONICALIZE_TOOLS
-
-RTEMS_CHECK_MULTIPROCESSING
-
-AM_CONDITIONAL(HAS_MP,test "$HAS_MP" = "yes")
-
-# shell/* wants to assign file descriptors to stdio file descriptors.
-AC_MSG_CHECKING([for assignable stdio])
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [#include <stdio.h>],
- [stdin = fopen("/tmp", "r")])],
- [HAVE_ASSIGNABLE_STDIO=yes],
- [HAVE_ASSIGNABLE_STDIO=no])
-AC_MSG_RESULT([$HAVE_ASSIGNABLE_STDIO])
-
-# serdbg exploits weak symbols
-AC_CACHE_CHECK([whether $CC supports function __attribute__((weak))],
-[rtems_cv_cc_attribute_weak],[
- AS_IF([test x"$GCC" = xyes],[
- save_CFLAGS=$CFLAGS
- CFLAGS=-Werror])
-
- AC_COMPILE_IFELSE([
- AC_LANG_PROGRAM(
- [void myfunc(char c) __attribute__ ((weak));
- void myfunc(char c) {}],
- [])],
- [rtems_cv_cc_attribute_weak=yes],
- [rtems_cv_cc_attribute_weak=no])
-
- AS_IF([test x"$GCC" = xyes],[
- CFLAGS=$save_CFLAGS])
-])
-
-AM_CONDITIONAL([LIBSHELL],[test x"$HAVE_ASSIGNABLE_STDIO" = x"yes"])
-AM_CONDITIONAL([LIBSERDBG],[test x"$rtems_cv_cc_attribute_weak" = x"yes"])
-
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-cpuuse/Makefile
-shell/Makefile
-devnull/Makefile
-dummy/Makefile
-dumpbuf/Makefile
-monitor/Makefile
-rtmonuse/Makefile
-serdbg/Makefile
-stackchk/Makefile
-capture/Makefile
-untar/Makefile
-mw-fb/Makefile
-wrapup/Makefile
-])
-AC_OUTPUT