summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-11-14 12:13:26 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-11-14 12:13:26 +0000
commit22b689b274c0d2ac2369e7969055dede3e0907cf (patch)
treea24b9226247ce73f5fa23ab3c4729ce7854dc108 /cpukit/libmisc/configure.ac
parent2002-11-13 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-22b689b274c0d2ac2369e7969055dede3e0907cf.tar.bz2
2002-11-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* capture/Makefile.am: Remove AUTOMAKE_OPTIONS. * serdbg/Makefile.am: Remove AUTOMAKE_OPTIONS. * serdbg/serdbgio.c: Add #include <unistd.h>. * shell/Makefile.am: Add RTEMS_LIBSHELL conditional. * wrapup/Makefile.am: Add RTEMS_LIBSHELL conditional. * configure.ac: Check for stdio assignments. Add RTEMS_LIBSHELL conditional.
Diffstat (limited to 'cpukit/libmisc/configure.ac')
-rw-r--r--cpukit/libmisc/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/libmisc/configure.ac b/cpukit/libmisc/configure.ac
index 141242d756..3907b776cd 100644
--- a/cpukit/libmisc/configure.ac
+++ b/cpukit/libmisc/configure.ac
@@ -29,6 +29,18 @@ RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
AM_CONDITIONAL(HAS_MP,test "$HAS_MP" = "yes")
+# shell/* wants to assign file descriptors to stdio file descriptors.
+AC_MSG_CHECKING([for assignable stdio])
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <stdio.h>],
+ [stdin = fopen("/tmp", "r")])],
+ [HAVE_ASSIGNABLE_STDIO=yes],
+ [HAVE_ASSIGNABLE_STDIO=no])
+AC_MSG_RESULT([$HAVE_ASSIGNABLE_STDIO])
+
+AM_CONDITIONAL([RTEMS_LIBSHELL],[test x"$HAVE_ASSIGNABLE_STDIO" = x"yes"])
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
cpuuse/Makefile