summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-11-08 13:27:25 +1100
committerChris Johns <chrisj@rtems.org>2017-11-11 16:14:59 +1100
commite6df806a3f46b5488e5e383add9cda43e0059dbe (patch)
tree560dabf7fec58d1d33cfaf419842ddbd085d8c16 /cpukit/libmisc/Makefile.am
parenttests: Use rtems_test_begin and rtems_test_end. (diff)
downloadrtems-e6df806a3f46b5488e5e383add9cda43e0059dbe.tar.bz2
tests: Use ld to map (wrap) printf, puts and putchar to tester functions.
- Remove the macro defines and the need for tmacro.h by remapping the symbols using ld's wrap option. - Remove FLUSH_OUTPUT, it was empty. - Move rtems_test_exit to libmisc/testsupport as a function. Update #3199.
Diffstat (limited to 'cpukit/libmisc/Makefile.am')
-rw-r--r--cpukit/libmisc/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libmisc/Makefile.am b/cpukit/libmisc/Makefile.am
index 786782931c..e1343ddf11 100644
--- a/cpukit/libmisc/Makefile.am
+++ b/cpukit/libmisc/Makefile.am
@@ -182,6 +182,7 @@ libtestsupport_a_SOURCES += testsupport/testbeginend.c
libtestsupport_a_SOURCES += testsupport/testbusy.c
libtestsupport_a_SOURCES += testsupport/testextension.c
libtestsupport_a_SOURCES += testsupport/testparallel.c
+libtestsupport_a_SOURCES += testsupport/testwrappers.c
## fsmount
noinst_LIBRARIES += libfsmount.a