summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2010-02-19 03:23:11 +0000
committerChris Johns <chrisj@rtems.org>2010-02-19 03:23:11 +0000
commitcca94a248bd6ce791b34e9bf3a704b535df3e5ef (patch)
tree395109d3c6dffa253542ecb82be29e6e96cff2f6 /cpukit/libmisc/Makefile.am
parent2010-02-19 Chris Johns <chrisj@rtems.org> (diff)
downloadrtems-cca94a248bd6ce791b34e9bf3a704b535df3e5ef.tar.bz2
2010-02-19 Chris Johns <chrisj@rtems.org>
* libblock/src/diskdevs.c: Create the devices as block devices. * libmisc/shell/main_debugrfs.c, libmisc/shell/main_mkrfs.c, libmisc/shell/main_mount_rfs.c: New. * libmisc/shell/main_msdosfmt.c: Change the command to mkdos and alias the old name. * libmisc/shell/shellconfig.h, libmisc/Makefile.am: Add RFS support. * libfs/src/rfs/rtems-rfs-shell.c, libfs/src/rfs/rtems-rfs-shell.h: Move the format command code into the shell file.
Diffstat (limited to 'cpukit/libmisc/Makefile.am')
-rw-r--r--cpukit/libmisc/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/cpukit/libmisc/Makefile.am b/cpukit/libmisc/Makefile.am
index 8955978608..ec0a9d29c5 100644
--- a/cpukit/libmisc/Makefile.am
+++ b/cpukit/libmisc/Makefile.am
@@ -95,8 +95,9 @@ libshell_a_SOURCES = shell/cat_file.c shell/cmds.c shell/internal.h \
shell/dd-misc.c shell/dd-position.c \
shell/main_hexdump.c shell/hexdump-conv.c shell/hexdump-display.c \
shell/hexdump-odsyntax.c shell/hexdump-parse.c shell/hexsyntax.c \
- shell/main_time.c shell/main_mknod.c \
- shell/main_setenv.c shell/main_getenv.c shell/main_unsetenv.c
+ shell/main_time.c shell/main_mknod.c shell/main_mount_rfs.c \
+ shell/main_setenv.c shell/main_getenv.c shell/main_unsetenv.c \
+ shell/main_mkrfs.c shell/main_debugrfs.c
if LIBNETWORKING
libshell_a_SOURCES += shell/main_mount_ftp.c shell/main_mount_tftp.c \