summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-05-30 11:49:08 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-05-30 11:49:08 +0000
commit3f4876a5d19b1f783e4263395de810ec398ada91 (patch)
tree1bcd8742c67703e2b0cae012b568d84380ee4f8a /cpukit/libcsupport/configure.ac
parent2003-05-29 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-3f4876a5d19b1f783e4263395de810ec398ada91.tar.bz2
Merger from rtems-4.6-branch
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/cpukit/libcsupport/configure.ac b/cpukit/libcsupport/configure.ac
index 6bf9b79ebb..ec2d3e2430 100644
--- a/cpukit/libcsupport/configure.ac
+++ b/cpukit/libcsupport/configure.ac
@@ -27,14 +27,15 @@ AM_CONDITIONAL(UNIX,test x"$RTEMS_CPU" = x"unix")
AM_CONDITIONAL(NEWLIB,test x"$RTEMS_USE_NEWLIB" = x"yes")
AS_IF([test x"$RTEMS_USE_NEWLIB" != x"yes"],[
-## Provide sys/cdefs.h only if the host doesn't.
+## Provide headers only if the host doesn't.
AC_CHECK_HEADERS([sys/cdefs.h],[NEED_SYS_CDEFS_H=no],[NEED_SYS_CDEFS_H=yes])
-# FIXME: These checks are only in here to provide
-# configuration-time diagnostics and are not really used.
- AC_CHECK_HEADERS([stdint.h inttypes.h])
+ AC_CHECK_HEADERS([stdint.h],[NEED_STDINT_H=no],[NEED_STDINT_H=yes])
+ AC_CHECK_HEADERS([inttypes.h],[NEED_INTTYPES_H=no],[NEED_INTTYPES=yes])
],[
## Using newlib, we provide sys/cdefs.h
NEED_SYS_CDEFS_H=yes
+ NEED_STDINT_H=yes
+ NEED_INTTYPES_H=yes
])
# FIXME: These checks are only in here to provide
@@ -75,6 +76,8 @@ AC_CHECK_DECLS([sbrk],,,[#include <unistd.h>])
AC_CHECK_FUNCS(strlcpy strlcat)
AM_CONDITIONAL([NEED_SYS_CDEFS_H],[test x"$NEED_SYS_CDEFS_H" = x"yes"])
+AM_CONDITIONAL([NEED_STDINT_H],[test x"$NEED_STDINT_H" = x"yes"])
+AM_CONDITIONAL([NEED_INTTYPES_H],[test x"$NEED_INTTYPES_H" = x"yes"])
AM_CONFIG_HEADER([src/config.h])