summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-03-19 00:49:15 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-03-19 00:49:15 +0000
commit8114f30144d26b72e073f77226c4250f4a0b02a4 (patch)
tree9a6f48e0d4c4acdc864f5ab8d44b906fc3972fa0 /cpukit/libcsupport/configure.ac
parent2003-03-18 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-8114f30144d26b72e073f77226c4250f4a0b02a4.tar.bz2
2003-03-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: AC_CHECK_FUNCS(strlcpy strlcat). * src/strlcat.c: New (extracted from pppd/utils.c). * src/strlcpy.c: New (extracted from pppd/utils.c). * Makefile.am: Add BSD_C_FILES, strlcat.c, strlcpy.c.
Diffstat (limited to 'cpukit/libcsupport/configure.ac')
-rw-r--r--cpukit/libcsupport/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/libcsupport/configure.ac b/cpukit/libcsupport/configure.ac
index d54cc2a39c..6bf9b79ebb 100644
--- a/cpukit/libcsupport/configure.ac
+++ b/cpukit/libcsupport/configure.ac
@@ -71,6 +71,9 @@ AC_CHECK_DECLS([ECHOPRT],,,[#include <termios.h>])
## BSD-ism, excluded from POSIX, but available on most platforms
AC_CHECK_DECLS([sbrk],,,[#include <unistd.h>])
+## Check if libc provides BSD's strlcpy/strlcat
+AC_CHECK_FUNCS(strlcpy strlcat)
+
AM_CONDITIONAL([NEED_SYS_CDEFS_H],[test x"$NEED_SYS_CDEFS_H" = x"yes"])
AM_CONFIG_HEADER([src/config.h])