summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <Jennifer.Averett@OARcorp.com>2010-06-22 20:03:41 +0000
committerJennifer Averett <Jennifer.Averett@OARcorp.com>2010-06-22 20:03:41 +0000
commite525f66b09e11427852da956424c71d784d828c6 (patch)
treeb134de04d80b384828099df538537db8b1845876 /cpukit/libcsupport/Makefile.am
parent2010-06-22 Joel Sherrill <joel.sherrilL@OARcorp.com> (diff)
downloadrtems-e525f66b09e11427852da956424c71d784d828c6.tar.bz2
2010-06-22 Jennifer Averett <Jennifer.Averett@OARcorp.com>
* libcsupport/Makefile.am, libcsupport/include/rtems/libio_.h: Moved method to free a node from a define to an external method. * libcsupport/src/freenode.c: New file.
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 368833b60b..d2e60c7c2f 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -84,7 +84,8 @@ ID_C_FILES = src/getegid.c src/geteuid.c src/getgid.c src/getgroups.c \
src/setpgid.c src/setsid.c
MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
- src/realloc.c src/_calloc_r.c src/free.c src/_free_r.c src/_malloc_r.c \
+ src/realloc.c src/_calloc_r.c src/_malloc_r.c \
+ src/free.c src/freenode.c src/_free_r.c \
src/_realloc_r.c src/__brk.c src/__sbrk.c src/mallocfreespace.c \
src/mallocinfo.c src/malloc_walk.c src/malloc_get_statistics.c \
src/malloc_report_statistics.c src/malloc_report_statistics_plugin.c \