summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorChristian Mauderer <Christian.Mauderer@embedded-brains.de>2017-11-13 09:21:28 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-17 07:26:41 +0100
commitddc339c51fa436e91eba083029bec3849997899e (patch)
treea44b0ac3edccfcc8a038f8d9d33cee8bf35f9ad9 /cpukit/libcsupport/Makefile.am
parentscore: Adjust _Scheduler_EDF_SMP_Insert_ready() (diff)
downloadrtems-ddc339c51fa436e91eba083029bec3849997899e.tar.bz2
cpukit: Add _arc4random_getentropy_fail.
Add a default implementation of _arc4random_getentropy_fail with an internal error. Update #3239.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 756526ae8e..038ac93548 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -116,7 +116,8 @@ TERMINAL_IDENTIFICATION_C_FILES += src/ttyname.c
LIBC_GLUE_C_FILES = src/__getpid.c src/__gettod.c src/__times.c \
src/truncate.c src/access.c src/stat.c src/lstat.c src/pathconf.c \
src/newlibc_reent.c src/newlibc_exit.c \
- src/kill_noposix.c src/utsname.c src/realpath.c
+ src/kill_noposix.c src/utsname.c src/realpath.c \
+ src/arc4random_getentropy_fail.c
BSD_LIBC_C_FILES = src/strlcpy.c src/strlcat.c src/issetugid.c