summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-07-13 10:19:04 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-07-15 08:46:36 +0200
commitc5d0ca91cff6cc62f2c7b1849a8986f2497c15ac (patch)
treef4e8029d7315e537381b3923e3fa8950d455379e /cpukit/libcsupport/Makefile.am
parentlibnetworking: Send the hostname if set in the network configuration. (diff)
downloadrtems-c5d0ca91cff6cc62f2c7b1849a8986f2497c15ac.tar.bz2
libcsupport: Workaround for GCC 5.1 and later
Disable an optimization which would lead to a recursive calloc() call in calloc().
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 7474079067..a5da5f1861 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -1,8 +1,9 @@
include $(top_srcdir)/automake/multilib.am
include $(top_srcdir)/automake/compile.am
-noinst_LIBRARIES = libcsupport.a
+noinst_LIBRARIES = libcsupport.a libcalloc.a
libcsupport_a_CPPFLAGS = $(AM_CPPFLAGS)
+libcalloc_a_CPPFLAGS = $(AM_CPPFLAGS)
include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = include/console.h
@@ -79,7 +80,7 @@ ID_C_FILES = src/getegid.c src/geteuid.c src/getgid.c src/getgroups.c \
src/seteuid.c src/setgid.c src/setuid.c src/setegid.c src/setpgid.c \
src/setsid.c
-MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
+MALLOC_C_FILES = src/malloc_initialize.c src/malloc.c \
src/realloc.c src/_calloc_r.c src/_malloc_r.c \
src/free.c src/_free_r.c \
src/_realloc_r.c src/mallocfreespace.c \
@@ -138,6 +139,9 @@ libcsupport_a_SOURCES += $(LIBC_GLUE_C_FILES) $(PASSWORD_GROUP_C_FILES) \
libcsupport_a_SOURCES += src/flockfile.c src/funlockfile.c src/ftrylockfile.c
+libcalloc_a_SOURCES = src/calloc.c
+libcalloc_a_CFLAGS = -fno-builtin
+
EXTRA_DIST = src/TODO src/CASES src/README
include $(srcdir)/preinstall.am