summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-09-06 08:54:24 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-09-07 07:40:19 +0200
commitbdbf1ffa6e81d75ab3ab7adc11e35b1ee1670c29 (patch)
tree06873599fc7a83f274e600611eb1d76888300447 /cpukit/libcsupport/Makefile.am
parentdosfs: Fix fat_file_update() (diff)
downloadrtems-bdbf1ffa6e81d75ab3ab7adc11e35b1ee1670c29.tar.bz2
Implement clock()
Newlib uses _times_r() in clock(). The problem is that the _times_r() clock frequency is defined by sysconf(_SC_CLK_TCK). The clock frequency of clock() is the constant CLOCKS_PER_SEC. FreeBSD uses getrusage() for clock(). Since RTEMS has only one process, the implementation can be simplified. Update #3121.
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 6091f08261..66a8aa06da 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -66,6 +66,7 @@ SYSTEM_CALL_C_FILES = src/open.c src/close.c src/read.c src/write.c \
src/fcntl.c src/fpathconf.c src/getdents.c src/fsync.c src/fdatasync.c \
src/pipe.c src/dup.c src/dup2.c src/symlink.c src/readlink.c \
src/chroot.c src/sync.c src/_rename_r.c src/statvfs.c src/utimes.c src/lchown.c
+SYSTEM_CALL_C_FILES += src/clock.c
## Until sys/uio.h is moved to libcsupport, we have to have networking
## enabled to compile these. Hopefully this is a temporary situation.