summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-08-13 11:29:13 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-08-20 10:10:25 +0200
commitbd5a138629771ae174927791fcc7515232a0e4fa (patch)
tree71fa47154f0364937612e79a5780e48e107d256e /cpukit/libcsupport/Makefile.am
parentbsp/lpc32xx: Specify scratch area alignment (diff)
downloadrtems-bd5a138629771ae174927791fcc7515232a0e4fa.tar.bz2
libcsupport: Add and use rtems_putc()
This reduces code size and provides a function similar to fputc().
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index ae233381a1..04d2455dfd 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -120,6 +120,7 @@ BSD_LIBC_C_FILES = src/strlcpy.c src/strlcat.c src/issetugid.c
libcsupport_a_SOURCES = src/gxx_wrappers.c src/getchark.c src/printk.c \
src/printk_plugin.c src/putk.c src/vprintk.c \
+ src/rtems_putc.c \
src/printf_plugin.c \
src/sup_fs_location.c \
src/sup_fs_eval_path.c \