summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-04-24 15:04:30 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-04-26 10:57:08 +0200
commitb7cf1ff7174377c65816908be427e1a76a5fa20f (patch)
tree13fb6a245c53df77b5e4559d809c7984559156ef /cpukit/libcsupport/Makefile.am
parentlibcsupport: Rename open_dev_console() (diff)
downloadrtems-b7cf1ff7174377c65816908be427e1a76a5fa20f.tar.bz2
libcsupport: Delete libc_wrapup()
Add and use rtems_libio_exit_helper. Add rtems_libio_exit(). The fclose(stdin) etc. makes no sense during exit. This would use the _REENT structure of the thread calling _exit().
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 42de63cf1d..25e18c69d0 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -56,6 +56,7 @@ BASE_FS_C_FILES = src/base_fs.c src/mount.c src/unmount.c src/libio.c \
src/mount-mgr.c src/mount-mktgt.c src/libio_init.c \
src/privateenv.c \
src/libio_helper_null.c \
+ src/libio_exit.c \
src/open_dev_console.c src/__usrenv.c src/rtems_mkdir.c
TERMIOS_C_FILES = src/cfgetispeed.c src/cfgetospeed.c src/cfsetispeed.c \