summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-04-24 14:30:42 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-04-26 10:57:08 +0200
commita290fbe946944385480cff7b388a6cd8b9d27d38 (patch)
tree0304af8b9649aa9b8073b13027d1f81ed07bfbff /cpukit/libcsupport/Makefile.am
parentlibcsupport: Remove superfluous assignments (diff)
downloadrtems-a290fbe946944385480cff7b388a6cd8b9d27d38.tar.bz2
libcsupport: Make LibIO helper const
Add and use rtems_libio_helper function type. Add and use rtems_libio_helper_null() instead of NULL pointer.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 76147c9873..42de63cf1d 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -55,6 +55,7 @@ ASSOCIATION_C_FILES = src/assoclocalbyname.c \
BASE_FS_C_FILES = src/base_fs.c src/mount.c src/unmount.c src/libio.c \
src/mount-mgr.c src/mount-mktgt.c src/libio_init.c \
src/privateenv.c \
+ src/libio_helper_null.c \
src/open_dev_console.c src/__usrenv.c src/rtems_mkdir.c
TERMIOS_C_FILES = src/cfgetispeed.c src/cfgetospeed.c src/cfsetispeed.c \