summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-02-10 10:36:26 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-02-10 10:42:58 +0100
commit28a08877ea961b0440b121b4617919136d6f342d (patch)
treec20ca716fad23ca298e98cf03bd8262150c8108e /cpukit/libcsupport/Makefile.am
parentMoved empty test in front of busy tests (diff)
downloadrtems-28a08877ea961b0440b121b4617919136d6f342d.tar.bz2
Added support functions for greedy heap allocation
Various tests must check program paths that result due to failed memory allocations from the heap. To avoid tinkering with internal heap structures throughout the test code these functions should be used.
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index ec06f901a1..15e55a1e51 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -107,7 +107,8 @@ MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
src/malloc_statistics_helpers.c src/posix_memalign.c \
src/rtems_memalign.c src/malloc_deferred.c src/malloc_sbrk_helpers.c \
src/malloc_dirtier.c src/malloc_p.h src/rtems_malloc.c \
- src/rtems_heap_extend.c
+ src/rtems_heap_extend.c \
+ src/rtems_heap_greedy.c
PASSWORD_GROUP_C_FILES = src/getpwent.c