summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:47:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:47:04 +0000
commit23c3f72e4d76daceacafd37d2580965ce79cfb80 (patch)
treeaaaea529330ff714b8c9a5c81a19610bc0b490ff /cpukit/libcsupport/Makefile.am
parent2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-23c3f72e4d76daceacafd37d2580965ce79cfb80.tar.bz2
2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com>
* include/rtems/bspIo.h, libcsupport/Makefile.am: Add genchark() for polled debug input from the same device as printk(). * libcsupport/src/getchark.c: New file.
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index 12395b1af7..f1361cfefe 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -99,7 +99,8 @@ LIBC_GLUE_C_FILES = src/__getpid.c src/__gettod.c src/__times.c \
BSD_LIBC_C_FILES = src/strlcpy.c src/strlcat.c
-libcsupport_a_SOURCES = src/gxx_wrappers.c src/printk.c src/printk_plugin.c \
+libcsupport_a_SOURCES = src/gxx_wrappers.c src/getchark.c src/printk.c \
+ src/printk_plugin.c \
$(BSD_LIBC_C_FILES) $(BASE_FS_C_FILES) $(MALLOC_C_FILES) \
$(ERROR_C_FILES) $(ASSOCIATION_C_FILES)