summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-27 11:44:48 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-28 11:23:53 +0100
commit01557b0c6e723627427195bb33bdfe0b125c70b1 (patch)
treeecd3bdb408cecd25bf24c25adb51dafdddedbc3a /cpukit/libcsupport/Makefile.am
parentbdbuf: Fix race condition with sync active flag (diff)
downloadrtems-01557b0c6e723627427195bb33bdfe0b125c70b1.tar.bz2
libcsupport: Delete malloc statistics
Use the heap handler statistics instead. Add heap walk option to MALLOC shell command. close #1367
Diffstat (limited to '')
-rw-r--r--cpukit/libcsupport/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index dfa8736ee0..1486194aa7 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -98,10 +98,9 @@ MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
src/realloc.c src/_calloc_r.c src/_malloc_r.c \
src/free.c src/_free_r.c \
src/_realloc_r.c src/mallocfreespace.c \
- src/mallocgetheapptr.c src/mallocsetheapptr.c \
- src/mallocinfo.c src/malloc_walk.c src/malloc_get_statistics.c \
- src/malloc_report_statistics.c src/malloc_report_statistics_plugin.c \
- src/malloc_statistics_helpers.c src/posix_memalign.c \
+ src/mallocgetheapptr.c src/mallocsetheapptr.c \
+ src/mallocinfo.c src/malloc_walk.c \
+ src/posix_memalign.c \
src/rtems_memalign.c src/malloc_deferred.c \
src/malloc_dirtier.c src/malloc_p.h src/rtems_malloc.c \
src/rtems_heap_extend_via_sbrk.c \