summaryrefslogtreecommitdiffstats
path: root/cpukit/libcsupport/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-08-10 13:15:30 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-08-10 13:15:30 +0000
commitbad55939df3c8a3c7ea58549c95e4a215b4bc0c3 (patch)
treec4779981eecbc5ecbe835e10d83f68053d4a47a3 /cpukit/libcsupport/Makefile.am
parentRegenerate. (diff)
downloadrtems-bad55939df3c8a3c7ea58549c95e4a215b4bc0c3.tar.bz2
2010-08-10 Joel Sherrill <joel.sherrill@oarcorp.com>
PR 1661/testing * libcsupport/Makefile.am, libcsupport/include/rtems/libcsupport.h: Add public methods to get/set malloc heap pointer so the tests do not have to peer behind the API. * libcsupport/src/mallocgetheapptr.c, libcsupport/src/mallocsetheapptr.c: New files.
Diffstat (limited to 'cpukit/libcsupport/Makefile.am')
-rw-r--r--cpukit/libcsupport/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/libcsupport/Makefile.am b/cpukit/libcsupport/Makefile.am
index e0643dc33e..acd864a290 100644
--- a/cpukit/libcsupport/Makefile.am
+++ b/cpukit/libcsupport/Makefile.am
@@ -92,6 +92,7 @@ MALLOC_C_FILES = src/malloc_initialize.c src/calloc.c src/malloc.c \
src/realloc.c src/_calloc_r.c src/_malloc_r.c \
src/free.c src/freenode.c src/_free_r.c \
src/_realloc_r.c src/mallocfreespace.c \
+ src/mallocgetheapptr.c src/mallocsetheapptr.c \
src/mallocinfo.c src/malloc_walk.c src/malloc_get_statistics.c \
src/malloc_report_statistics.c src/malloc_report_statistics_plugin.c \
src/malloc_statistics_helpers.c src/posix_memalign.c \