summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/macros/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:29:41 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:29:41 +0000
commit5a6ad2a2e91adfd4e38f8865418ce7a5ada76ca3 (patch)
treeeb4b7dc58dcf8fb5624c97eaa8ce4885522b537f /cpukit/itron/macros/Makefile.am
parent2001-10-16 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-5a6ad2a2e91adfd4e38f8865418ce7a5ada76ca3.tar.bz2
2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/itronsys/Makefile.am: Remove. * include/rtems/Makefile.am: Remove. * include/rtems/itron/Makefile.am: Remove. * inline/rtems/Makefile.am: Remove. * inline/rtems/itron/Makefile.am: Remove. * macros/rtems/Makefile.am: Remove. * macros/rtems/itron/Makefile.am: Remove. * include/Makefile.am: handle subdirs. * inline/Makefile.am: handle subdirs. * macros/Makefile.am: handle subdirs. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--cpukit/itron/macros/Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/cpukit/itron/macros/Makefile.am b/cpukit/itron/macros/Makefile.am
index 32269fcdcd..9ac3af11c1 100644
--- a/cpukit/itron/macros/Makefile.am
+++ b/cpukit/itron/macros/Makefile.am
@@ -2,9 +2,26 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
-SUBDIRS = rtems
+include_rtems_itrondir = $(includedir)/rtems/itron
+
+$(PROJECT_INCLUDE)/rtems/itron:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%: %
+ $(INSTALL_DATA) $< $@
+
+if MACROS
+include_rtems_itron_HEADERS = rtems/itron/eventflags.inl \
+ rtems/itron/fmempool.inl rtems/itron/intr.inl rtems/itron/mbox.inl \
+ rtems/itron/msgbuffer.inl rtems/itron/network.inl rtems/itron/port.inl \
+ rtems/itron/semaphore.inl rtems/itron/sysmgmt.inl rtems/itron/task.inl \
+ rtems/itron/time.inl rtems/itron/vmempool.inl
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/itron \
+ $(include_rtems_itron_HEADERS:%=$(PROJECT_INCLUDE)/%)
+endif
+
+all-local: $(PREINSTALL_FILES)
-include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am