summaryrefslogtreecommitdiffstats
path: root/cpukit/httpd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
commite6d8fe4717c301925408786aee585fb96912e445 (patch)
tree18a65119b8150bfc661d3fee629eb8361d4e7555 /cpukit/httpd/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e6d8fe4717c301925408786aee585fb96912e445.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am, arpa/Makefile.am, machine/Makefile.am, net/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, rtems/Makefile.am, rtems_servers/Makefile.am, rtems_webserver/Makefile.am, sys/Makefile.am, vm/Makefile.am: Apply include_*HEADERS instead of H_FILES. * include/Makefile.am: Remove. * Makefile.am: Add handling of *.h files. * configure.in: Remove include/Makefile.
Diffstat (limited to '')
-rw-r--r--cpukit/httpd/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/cpukit/httpd/Makefile.am b/cpukit/httpd/Makefile.am
index 3870951683..1cbb77b00d 100644
--- a/cpukit/httpd/Makefile.am
+++ b/cpukit/httpd/Makefile.am
@@ -4,6 +4,8 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_goaheaddir = $(includedir)/goahead
+
LIBNAME = lib.a
LIB = $(ARCH)/$(LIBNAME)
@@ -46,6 +48,9 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/rtems_webserver.h \
$(PROJECT_INCLUDE)/goahead $(H_FILES:%.h=$(PROJECT_INCLUDE)/goahead/%.h)
if HAS_POSIX
+include_HEADERS = rtems_webserver.h
+include_goahead_HEADERS = $(H_FILES)
+
all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
endif