summaryrefslogtreecommitdiffstats
path: root/cpukit/httpd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-05 16:07:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-09-05 16:07:35 +0000
commit9b28bea577dc0d6781d2895b61c07a5d311d24b5 (patch)
treed44a0b3ca8230f9d0c99a5fb3044829f312637cd /cpukit/httpd/Makefile.am
parent2000-09-04 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-9b28bea577dc0d6781d2895b61c07a5d311d24b5.tar.bz2
2000-09-04 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* kern/Makefile.am, lib/Makefile.am, libc/Makefile.am, net/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, pppd/Makefile.am, rtems/Makefile.am, rtems_servers/Makefile.am, rtems_webserver/Makefile.am, wrapup/Makefile.am: Include compile.am
Diffstat (limited to 'cpukit/httpd/Makefile.am')
-rw-r--r--cpukit/httpd/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/cpukit/httpd/Makefile.am b/cpukit/httpd/Makefile.am
index c85580a0c2..3b99ffa0ad 100644
--- a/cpukit/httpd/Makefile.am
+++ b/cpukit/httpd/Makefile.am
@@ -7,10 +7,10 @@ AUTOMAKE_OPTIONS = foreign 1.4
LIBNAME = lib.a
LIB = $(ARCH)/$(LIBNAME)
-C_FILES = asp.c balloc.c base64.c default.c ejlex.c ejparse.c emfdb.c \
- form.c h.c handler.c md5c.c mime.c misc.c webpage.c ringq.c rom.c \
- security.c socket.c sym.c uemf.c um.c url.c value.c webrom.c webs.c \
- websuemf.c webmain.c
+C_FILES = asp.c balloc.c base64.c default.c ejlex.c ejparse.c emfdb.c form.c \
+ h.c handler.c md5c.c mime.c misc.c webpage.c ringq.c rom.c security.c \
+ socket.c sym.c uemf.c um.c url.c value.c webrom.c webs.c websuemf.c \
+ webmain.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -18,6 +18,7 @@ OBJS = $(C_O_FILES)
H_FILES = ej.h ejIntrn.h emfdb.h md5.h uemf.h um.h webs.h wsIntrn.h
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
#
@@ -41,9 +42,8 @@ $(PROJECT_INCLUDE)/goahead/%.h: %.h
$(PROJECT_INCLUDE)/rtems_webserver.h: rtems_webserver.h
$(INSTALL_DATA) $< $@
-PREINSTALL_FILES += $(PROJECT_INCLUDE) \
- $(PROJECT_INCLUDE)/rtems_webserver.h $(PROJECT_INCLUDE)/goahead \
- $(H_FILES:%.h=$(PROJECT_INCLUDE)/goahead/%.h)
+PREINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/rtems_webserver.h \
+ $(PROJECT_INCLUDE)/goahead $(H_FILES:%.h=$(PROJECT_INCLUDE)/goahead/%.h)
if HAS_POSIX
all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)