summaryrefslogtreecommitdiffstats
path: root/cpukit/ftpd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 04:04:46 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 04:04:46 +0000
commitfa73ccb0b85e09122e7dcde429e49b8448e696d7 (patch)
treecddb4001bce59131b5b1b999b788559a5cdd7487 /cpukit/ftpd/Makefile.am
parent2005-02-08 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-fa73ccb0b85e09122e7dcde429e49b8448e696d7.tar.bz2
2005-02-08 Ralf Corsepius <ralf.corsepius@rtems.org>
* configure.ac: Add new header guard to cpuopts.h. * Makefile.am: Add libfs, libblock, ftpd header install rules. * libfs/Makefile.am, libblock/Makefile.am, ftpd/Makefile.am: Remove header install rules.
Diffstat (limited to 'cpukit/ftpd/Makefile.am')
-rw-r--r--cpukit/ftpd/Makefile.am19
1 files changed, 1 insertions, 18 deletions
diff --git a/cpukit/ftpd/Makefile.am b/cpukit/ftpd/Makefile.am
index 5e88bd8296..c76448b7e2 100644
--- a/cpukit/ftpd/Makefile.am
+++ b/cpukit/ftpd/Makefile.am
@@ -5,18 +5,12 @@
include $(top_srcdir)/automake/compile.am
if HAS_NETWORKING
-include_rtemsdir = $(includedir)/rtems
-include_rtems_HEADERS = ftpd.h
-
project_lib_LIBRARIES = libftpd.a
libftpd_a_SOURCES = ftpd.c ftpd.h
-libftpd_a_CPPFLAGS = $(AM_CPPFLAGS)
endif
all-local: $(PREINSTALL_FILES)
-PREINSTALL_DIRS =
-PREINSTALL_FILES =
TMPINSTALL_FILES =
$(PROJECT_LIB)/$(dirstamp):
@@ -25,22 +19,11 @@ $(PROJECT_LIB)/$(dirstamp):
TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
if HAS_NETWORKING
-$(PROJECT_INCLUDE)/rtems/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/rtems
- @: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-
-$(PROJECT_INCLUDE)/rtems/ftpd.h: ftpd.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/ftpd.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/ftpd.h
-
$(PROJECT_LIB)/libftpd.a: libftpd.a $(PROJECT_LIB)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_LIB)/libftpd.a
TMPINSTALL_FILES += $(PROJECT_LIB)/libftpd.a
endif
-CLEANFILES = $(PREINSTALL_FILES)
-DISTCLEANFILES = $(PREINSTALL_DIRS)
-CLEANFILES += $(TMPINSTALL_FILES)
+CLEANFILES = $(TMPINSTALL_FILES)
include $(top_srcdir)/automake/local.am