summaryrefslogtreecommitdiffstats
path: root/cpukit/ftpd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 08:43:12 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 08:43:12 +0000
commit7406623261c51b1b013f6f2562ab763f114584a9 (patch)
treee810e332e4059c34591d051d70e8f10080eb05e9 /cpukit/ftpd/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7406623261c51b1b013f6f2562ab763f114584a9.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. Apply dirstamps to preinstallation. * pppd/Makefile.am: Ditto. * rtems_servers/Makefile.am: Ditto. * rtems_telnetd/Makefile.am: Ditto. * rtems_webserver/Makefile.am: Ditto. * wrapup/Makefile.am: Ditto.
Diffstat (limited to '')
-rw-r--r--cpukit/ftpd/Makefile.am27
1 files changed, 17 insertions, 10 deletions
diff --git a/cpukit/ftpd/Makefile.am b/cpukit/ftpd/Makefile.am
index 967ff147b5..a98feff791 100644
--- a/cpukit/ftpd/Makefile.am
+++ b/cpukit/ftpd/Makefile.am
@@ -32,15 +32,22 @@ endif
.PRECIOUS: $(LIB)
-PREINSTALL_FILES = $(PROJECT_INCLUDE) \
- $(include_HEADERS:%=$(PROJECT_INCLUDE)/%) \
- $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
-
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-$(PROJECT_INCLUDE)/rtems:
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/rtems/%.h: %.h
- $(INSTALL_DATA) $< $@
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)
+ @: > $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
+
+if HAS_NETWORKING
+$(PROJECT_INCLUDE)/rtems/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems
+ @: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+
+$(PROJECT_INCLUDE)/ftpd.h: ftpd.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/ftpd.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/ftpd.h
+endif
include $(top_srcdir)/automake/local.am