summaryrefslogtreecommitdiffstats
path: root/cpukit/ftpd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-03 13:21:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-03 13:21:38 +0000
commit4bf1801d0d6fa7bcf7488f7f3cc5c39fafeac7d2 (patch)
tree5a28ef12908ea03bf2125df5b280ed1974dd02e5 /cpukit/ftpd/Makefile.am
parentFixed spelling errors. (diff)
downloadrtems-4bf1801d0d6fa7bcf7488f7f3cc5c39fafeac7d2.tar.bz2
Patches rtems-rc-20000118-7.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that contains the automake files for libnetworking plus a couple of minor fixes. [Now only one unused/unsupported Makefile.in remains (./c/src/lib/libbsp/hppa1.1/pxfl/Makefile.in).] To apply: patch -p1 < rtems-rc-20000118-7.diff /bin/sh rtems-rc-20000118-7.rm /bin/sh rtems-rc-20000118-7.add ./bootstrap Notes: * I have tested this one by building all BSPs for m68k, powerpc, sh and unix with toolchains built since last weekend. * I did not touch libnetworking's directory layout.
Diffstat (limited to 'cpukit/ftpd/Makefile.am')
-rw-r--r--cpukit/ftpd/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/cpukit/ftpd/Makefile.am b/cpukit/ftpd/Makefile.am
new file mode 100644
index 0000000000..77d1677844
--- /dev/null
+++ b/cpukit/ftpd/Makefile.am
@@ -0,0 +1,31 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = lib.a
+LIB = $(ARCH)/$(LIBNAME)
+
+C_FILES = ftpd.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = ftpd.c ftpd.h
+
+include $(top_srcdir)/../../../automake/local.am