summaryrefslogtreecommitdiffstats
path: root/cpukit/ftpd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-14 13:35:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-14 13:35:47 +0000
commit451198be1408317bae0c56f1eb29593ebe5b4ef2 (patch)
tree0b7af62be651e092970abbb48955b984230f4071 /cpukit/ftpd/Makefile.am
parent2001-06-14 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-451198be1408317bae0c56f1eb29593ebe5b4ef2.tar.bz2
2001-06-14 Joel Sherrill <joel@OARcorp.com>
* rtems_servers/telnetd.c, shell/telnetd.h: Moved from libmisc/shell so the network stack to address network depenendency. * rtems_servers/Makefile.am: Modified to reflect above.
Diffstat (limited to '')
-rw-r--r--cpukit/ftpd/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/cpukit/ftpd/Makefile.am b/cpukit/ftpd/Makefile.am
index bbba6e064c..a4f4e019f8 100644
--- a/cpukit/ftpd/Makefile.am
+++ b/cpukit/ftpd/Makefile.am
@@ -34,9 +34,17 @@ EXTRA_DIST = ftpd.c ftpd.h
include_HEADERS = ftpd.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+include_rtems_HEADERS = telnetd.h
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE) \
+ $(include_HEADERS:%=$(PROJECT_INCLUDE)/%) \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
include $(top_srcdir)/../../../automake/local.am