summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-04-06 02:38:22 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-04-06 02:38:22 +0000
commite9d907641219e9cc121f3656fc3e19ca3c10e23c (patch)
tree0b7f93e3c38385dc6f30a2bc68d2431fff5d8cd8 /cpukit/configure.ac
parent2004-04-06 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-e9d907641219e9cc121f3656fc3e19ca3c10e23c.tar.bz2
2004-04-06 Ralf Corsepius <ralf_corsepius@rtems.org>
* aclocal/rtems-cpu-subdirs.m4: Remove (Unused). * configure.ac: Remove RTEMS_CPU_SUBDIRS([score/cpu]). Add RTEMS_CHECK_SYSV_UNIX. Add score/cpu/*/Makefile. * score/cpu/Makefile.am: Add DIST_SUBDIRS.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 27c0133c68..e487857085 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -47,8 +47,6 @@ RTEMS_CHECK_POSIX_API
RTEMS_CHECK_ITRON_API
RTEMS_CHECK_NETWORKING
-RTEMS_CPU_SUBDIRS([score/cpu])
-
AS_IF([test x"$HAS_NETWORKING" = x"yes"],[
## FIXME: Should better use a feature-based test
AC_MSG_CHECKING([whether CPU supports librpc])
@@ -91,6 +89,10 @@ AC_CHECK_FUNCS([bcopy bcmp])
AC_CHECK_FUNCS([isascii fileno])
AS_IF([test x"${RTEMS_CPU}" = x"unix"],[
+## FIXME: This check is doubtful
+AS_IF([test "$HAS_MP" = "yes"],
+ [RTEMS_CHECK_SYSV_UNIX])
+
## The code fragment below had been used in tools/cpu/unix/gensize.c.
## FIXME:
## * The pad very likely is not necessary.
@@ -311,6 +313,18 @@ rtems/Makefile
sapi/Makefile
score/Makefile
score/cpu/Makefile
+score/cpu/arm/Makefile
+score/cpu/c4x/Makefile
+score/cpu/h8300/Makefile
+score/cpu/i386/Makefile
+score/cpu/i960/Makefile
+score/cpu/m68k/Makefile
+score/cpu/mips/Makefile
+score/cpu/or32/Makefile
+score/cpu/powerpc/Makefile
+score/cpu/sh/Makefile
+score/cpu/sparc/Makefile
+score/cpu/unix/Makefile
posix/Makefile
itron/Makefile
libblock/Makefile